Authors.txt not working on Ubuntu 20.04 on WSL

I’m trying out a SubGit migration and had the opportunity of testing on both native Windows 10 and Ubuntu 20.04 on WSL. Initially I imported through Windows, but, to acclimatize myself more with Linux systems, I switched to importing periodically the same repo by running the import from inside Ubuntu-WSL (i.e. I navigated to the same folder in the Ubuntu terminal and executed subgit import .). I soon noticed that the commits imported via Ubuntu-WSL had wrong author names. Instead of having Full Name <> they had svnname <> as if the authors.txt file was ignored and instead the default scheme was used (with the company domain from the config file).

I tried the same configuration on a CentOS 7 VM and it works fine. I tried with a brand new repo created entirely from within Ubuntu-WSL and it still has the problem.

SubGit is installed in Ubuntu-WWL via the deb package. It is installed in CentOS using these instructions. All instances use SubGit 3.3.11.


It appears that the problem exists only when using the /mnt/c/... part of the filesystem.

Hello Constantine,

judging from the description, it’s an issue with paths, SubGit just unable to find the authors file and thus cannot use it. I’m not sure what is the reason for that in WSL, unfortunately, don’t have a system to test it right away. The installation with the guide you mentioned is correct, especially with the deb package, so this part hardly can introduce any issues, the issue comes from the WSL, either permissions issue or some specifics with pwd command, maybe.