Errors importing SVN History

I keep getting errors like the following:

Last synchronization failed with an error: tag ‘refs/tags/3.05’ unexpectedly refers to commit 1188f655d7a904e057f5cdef74a3009887279bd6 which is not synchronized with SVN repository

It seems to keep failing with similar error messages. Any idea how to fix this?

Which SVN Mirror add-on version are you using? This sounds like a problem we should have solved in the latest version.

Hello Tyler

as Dmitry has mentioned, we indeed implemented a fix for a similar problem in the latest version 3.4.6, could you advise, is that version is installed on your server or are you using oldest one? Also, could you let us know what is the Bitbucket server that you use?

We would need to investigate the issue a little deeper to develop a solution, could you please provide us with the add-on logs? If you’re using v.3.4.6, then the logs can be collected in the add-on UI on Repository Settings - SVN Mirror - Support tab but the Create zip button. In the case of an earlier add-on version, the logs should be collected directly from the server filesystem; repository-specifics logs reside at the following path:


global add-on logs and Bitbucket server logs reside here:


We would need both repository-specific and global add-on logs and bitbucket logs for at least two or three last days.

@ildarhm @dmitry.pavlenko Yes, that was the problem. I updated from 3.4.3 to 3.4.6 and now it works! Thanks, I should have checked that first.