IMPORT FAILED - error svn E175002: SSL peer shut down incorrectly

Dear tmatesoft support,

I’m having an issue with an import from SVN to GIT. the repository SVN is like really big and the conversion of commits takes approximately more than 10 hours.

So I guess there’s a timeout and the job fails at 90% with an Import failed (probably because a file might be too big)

I can’t give the logs publicly, but I can give you the error I had on a .txt. (I’m sorry about this, if I can do something else to show you what happend it would be cool). I’ve tried to put a var HttpSpooling = true, so the job can move forward when it becomes a long one, but it didn’t work out, same error as previously.

Thank you in advance guys.
Kindest regards,

I’m sorry but I changed the priority to a bit higher (if that’s fine for you guys), I also added the version of Subgit I have. Let me know if you need anything else.



first I’d like to note that 3.2.4 is a very old SubGit version, the current is 3.3.8 and a lot of issues were resolved since 3.2.4, so I’d like to recommend upgrading SubGit to the latest version, it is quite probable that the upgrade will resolve the problem. The newest version can be downloaded here:

As for the error “E175002: SSL peer shut down incorrectly” itself – this particular error means that Subversion server has closed SSL connection with SVN client because of a timeout error. This kind of error usually occurs when SVN client receives a lot of data from SVN server.

If you have admin privileges on your Subversion server, you can increase connect and read timeouts in Apache configuration, so SVN server is more tolerable to long running read operations. Please use Apache Timeout directive for increasing the timeout value:

@ildarhm First of all thank you for your help, it’s really kind of you. I’ve upgraded to 3.3.8. I have actually tried something else, and I do avoid this error. What I’m trying is to exclude the branches I do not need, but in fact include the ones I need. the connection doesn’t close anymore since it’s taking less than 10 hours,

though I have another one due to my scripts :

error: 'excludeBranches' option value has unsupported format
error: "branches/save-130802:refs/heads/save-130802" pattern should not contain ':' or ';' characters
remote: error: cannot lock ref 'refs/heads/BR_2_8_0': 'refs/heads/BR_2_8_0/interop' exists; cannot create 'refs/heads/BR_2_8_0'[K
remote: error: cannot lock ref 'refs/heads/BR_2_8_0_MTOM': 'refs/heads/BR_2_8_0_MTOM/interop' exists; cannot create 'refs/heads/BR_2_8_0_MTOM'[K
remote: error: cannot lock ref 'refs/heads/save-130802': 'refs/heads/save-130802/interop' exists; cannot create 'refs/heads/save-130802'[K
To https://x:x@x.xx/git/x/x.git
 ! [rejected]        0.18.x -> 0.18.x (non-fast-forward)
 ! [rejected]        0.18.x._ex_0.18.5 -> 0.18.x._ex_0.18.5 (non-fast-forward)
 ! [rejected]        0.19.x -> 0.19.x (non-fast-forward)
 ! [rejected]        CENTER -> CENTER (non-fast-forward)
 ! [rejected]        master -> master (non-fast-forward)
 ! [remote rejected] BR_2_8_0 -> BR_2_8_0 (failed to update ref)
 ! [remote rejected] BR_2_8_0_MTOM -> BR_2_8_0_MTOM (failed to update ref)
 ! [remote rejected] save-130802 -> save-130802 (failed to update ref)
error: failed to push some refs to 'https://x:x@x.xx/git/x/x.git'
hint: Updates were rejected because the tip of your current branch is behind
hint: its remote counterpart. Merge the remote changes (e.g. 'git pull')
hint: before pushing again.
hint: See the 'Note about fast-forwards' in 'git push --help' for details.
remote: error: cannot lock ref 'refs/tags/archives': 'refs/tags/archives/0.0.7' exists; cannot create 'refs/tags/archives'[K
remote: error: cannot lock ref 'refs/tags/reviews': 'refs/tags/reviews/20100708-RevueInitiale' exists; cannot create 'refs/tags/reviews'[K

it feels like my script isn’t correct and I can’t find out what’s wrong. note : the ones he rejects are the one I want to exclude and I exactly specify them as excluded. I’ve tried to put the branches in a different string format :


but doesn’t work either

I have attached my scripts and hidden my urls in.

#param $excludeBranches : String
set_exclude_branches () {
	if [ "$1" = "none" ]; then
		echo "no exclusion";
		echo "couples exclusions"
		for str in ${1//;/ } ; do
	   		echo "+ \"$str\""

	   		branch="\\\texcludebranches = $str"
			sed -i "/^[[:blank:]]\+trunk = /a $branch" $configFileUrl

And I get this var back into,
please find attached the archive of my scripts.

Thank you so much for helping me out, I moved forward on my problem and it is really cool.
Kindest regards, have a nice Monday.


honestly, I haven’t got the situation completely: the scripts should prepare a repository and perform an initial import, as far as I understood, but the error appeared during some push. Something was changed in a working copy and pushed back to a mirrored repository, I assume, but it’s not completely clear what’s been changed. Could you please advise what it was – what was the repository and what was changed and pushed? Also, may I ask you to provide us with logs from that repository, the logs will provide more information about what might have gone wrong.