SubGit Configure Error cannot find Skunkworks

error: svn: E160013: File not found: revision 31418, path ‘/SkunkWorks’
error: svn: E160013: ‘/svn/AnyLync_Project/!svn/bc/31418’ path not found: 404 Not Found (
error: Unexpected error has occurred; please report along with the logs (’/home/ubuntu/AnylyncProject/’) (7.2 KB)

Hello Ronnie,

this error came right from the SVN and it means that the path /SkunkWorks hasn’t been found in the revision 31418. The most probably cause is a problem in the SVN repository database, some of the files appear to be absent there. To check this out try to run the following commands:

svn log -v


svn checkout -r 31418

Most probably this command will also fail with the same or similar error.
It would also worth checking the repository health on the SVN server with the following command:

svnadmin verify <path to SVN repository>

The best way to resolve the issue is to fix the problem in the SVN repository so that the database is in a consistent state and SVN returns no errors. If that is not possible, the issue can be worked around by starting the import from a revision later that the problematic one. This workaround would not allow to use the layout auto option for the subgit configure command, so the mapping configuration should be created manually. The steps for the workaround are:

  • create a new Git repository and a default SubGit configuration for the import:

    subgit configure --layout std Memori.git
  • set the svn.minimalRevision setting in the configuration file to a revision later than the problematic one:

    git config -f Memori.git/subgit/config svn.minimalRevision 31419
  • edit the mapping configuration in the Memori.git/subgit/config config file adjusting it for the Memori repository. Just in case, here is our article describing the mapping configuration:

    TMate SubGit: Branches and tags mapping

I’d like to note, though, that this 31418 revision may not be a single revision that has problems, so it cannot be excluded that another issue like this will appear during the initial import.

Worked perfectly. Thanks very much!