Tags do not get picked up


I want to use SVN Mirror to synchronize a svn repo into git/Bitbucket.

I have installed the licensed version and it works fine, except a set of tags do not get imported.

They look like this
and so on

I used this mapping:
tags = tags/jenkins/123:refs/tags/123

But the tag does not get picked up. After the synchronization the tag does not exist in git/Bitbucket. Other tags get imported but not these.

I also tried this
tags = tags/jenkins/:refs/tags/

With the same result.

Any ideas?



This setting

indeed should not work, but the first one you mentioned looks good and should pick up the tags. It’s not completely clear from the description what is the reason for that behavior, it needs a deeper investigation. May I ask you to collect logs from the affected repository? It can be done in the add-on UI in the repository, the ‘Create ZIP’ feature on the Support tab.


thank you for your answer. I looked deeper into it and found, that it was a permission issue in subversion. Those tags I was trying to mirror had a special permission on them, which I was not aware of.

It would be helpful if those rules, which are not matching any tree in subversion would get reported. If I try to map something and the matching rule does not hit any folder in the source, issuing at least a warning would be nice.

I fixed the permissions now and now the tags in question get picked up.

Thank you!



thank you for letting me know and thank you for your suggestions, we will discuss it with dev team.