While migrating code from SVN to Bitbucket: File not found error is coming from different path (different from the SVN Source path )

Hi Team,

While migrating code from SVN to Bitbucket: File not found error is coming.
SVN Repo URL: https://svn.dts.fm.rbsgrp.net/irexotics_hybrids/Fire/Fire3/

Error message coming: Command Failed : DEMO_20_Jun / Fire_19_Jun
File not found: revision 52631, path '/Fire/Fire2/fire-jee/branches/releases/

If you notice the path which is coming is error message is different. We provided https://svn.dts.fm.rbsgrp.net/irexotics_hybrids/Fire/Fire3/ in our SVN source URL but in error message SVN URL is coming different i.e. https://svn.dts.fm.rbsgrp.net/irexotics_hybrids/Fire/Fire2

Attached is the directory structure of our SVN repo. We wanted to migrate data from Fire3 directory structure.

We checked the revision history for that particular revision

[proddts@lonrs10155] /opt/app/dts/Toolset/apache2210_svn1611/conf/> svn log file:///dts_data0/AppData/SVN/IRExoticsHybrids/irexoticshybrids/Fire/Fire2/fire-jee/branches/releases/

r52631 | ippilis | 2011-02-16 09:45:28 +0000 (Wed, 16 Feb 2011) | 1 line

FIRE-000 added a launcher for fire prl cache

[proddts@lonrs10155] /opt/app/dts/Toolset/apache2210_svn1611/conf/>

Please help us to understand:

  1. Why system is referring to different path (other than which we provide in Source URL)?
  2. How we can solve this issue? Do we need to do something at SVN side or Bitbucket side?

In case any other information require from our side then please let us know.

Thanks & Regards,
Namit Narang

Hello Namit

may we have the add-on logs from that repository for analysis? Logs can be collected on the Repository Settings - SVN Mirror - Support tab by the Create zip button. Could you advise do I understand correctly that the issue occurs at the configuration stage before the Import/Mirror button has been pressed? Also, could you please try to access the SVN repository remotely over https as it set in the Bitbucket and provide us with the svn log for that revision:

svn log https://svn.dts.fm.rbsgrp.net/irexotics_hybrids/Fire/Fire3 -r 52631

@ildarhm: Thanks for looking into this issue.
yes, your understanding is correct that this error message is coming before the Import button.
I am not able to find way to create support zip as you described in your comment. I am not getting Support tab in Repository Setting --> SVN mirror (attached is the screen shot for the same). Please let me know if I am missing anything here.

Attached is log from SVN. I guess this log is coming correctly because r52631 is not available at this path /Fire/Fire3 instead this is available for path /Fire/Fire2 as i described in my first comment.

We are able to access that repo. Please find the attached screenshot for the same.


the Fire/Fire3 directory might have been renamed from Fire2 somewhen back in time and that may be the reason why this the add-on tries to reach that path. It’s still unclear, however, whether this is the real file absence in SVN or the add-on is doing something wrong. To find this out we would need more information, may we additionally have the following logs:

svn log https://svn.dts.fm.rbsgrp.net/irexotics_hybrids/Fire/Fire2
svn log https://svn.dts.fm.rbsgrp.net/irexotics_hybrids/Fire/Fire3
svn log https://svn.dts.fm.rbsgrp.net/irexotics_hybrids -r 52631

Meanwhile, it’s still possible to proceed with the import even despite this issue. Instead of using ‘Automatic configuration’ select ‘Manual Configuration’ – in this case the add-on doesn’t search the SVN history, it just creates a mapping configuration for ‘standard’ layout. Your repository has that exact layout, so you can proceed with this configuration making no changes to it.

Thanks for your suggestion.
I will try with the Manual Configuration.
Please find attached log files as requested.


Could you advise if you have tried the Manual configuration approach and if it worked for you?

@ildarhm: Sorry for replying late on this.
Yes, we tried manually and it’s work for us.


thank you for letting us know